最新消息:xilo的博客2016重新上线,感谢新老朋友的热情关注。

JQuery validator 在 IE6 下失效

开发 xilo 485浏览 0评论

JQuery validator 在IE6下失效, 谁让jquery-plugin-validation是外国人编写的。默认iso-8859-1编码。所以jquery.validator.js在其他编码中有乱码,解决方法有两种:

1. 去掉乱码 (修改源代码)
2. 加上charset, 例如: <script src=”/js/jquery.validate.pack.js” type=”text/javascript” charset=”iso-8859-1″></script>

(附:网上有人说与ie6对pack版支持不好,用min即可解决,我尝试了下,此法行不通。)

(注:IE8相对IE7容错功能要好些,那个在js中容易忽视的逗号,IE8通过,IE7报错。唉!万恶的IE6啊,万恶的IE啊!)

转载请注明:xilo blog » JQuery validator 在 IE6 下失效

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址